Revista Informática

Como Instalar FireSheep en Ubuntu/Debian

Publicado el 27 noviembre 2010 por Angelverde

Para los interesados en el tema, recientemente fue lanzada la versión de FireSheep con Soporte para GNU/Linux. Si tienes interés en probar esta extensión de Firefox sigue las instrucciones.

Primero obtenemos el código fuente, el comando colocara el código fuente en una carpeta llamada firesheep:
git clone https://github.com/codebutler/firesheep.git
cd firesheep
git submodule update --init

Ahora falta conseguir las herramientas para compilarlo, ejecutamos:

sudo apt-get install autoconf libtool libpcap-dev libboost-all-dev libhal-dev xulrunner-1.9.2-dev

Para concluir compilamos. Ejecutamos el archivo .sh y cruzamos los dedos para que todo salga a la perfección:

./autogen.sh & make

Con esto conseguiremos la extensión para Firefox firesheep.xpi en la carpeta ./firesheep/build. Como siempre hay que reiniciar el navegador después de instalar. Si lo pruebas no olvides comentar como te fue, ya que los resultados pueden variar de equipo a equipo. Lo probe en un AMD64, compilo y ejecuto sin problemas.

¿Tienes prisa? Instala en un solo comando:

sudo apt-get install autoconf libtool libpcap-dev libboost-all-dev libhal-dev xulrunner-1.9.2-dev & git clone https://github.com/codebutler/firesheep.git & cd firesheep & git submodule update --init & ./autogen.sh & make & ./build/firesheep.xpi

 


Volver a la Portada de Logo Paperblog

LOS COMENTARIOS (3)

Por  nan_dvdm
publicado el 12 junio a las 06:29
Denunciar

me dice: firesheep no ha podido ser instalado por que no es compatible con firefox 4.0.1.

Por  Ardillas en la red
publicado el 25 enero a las 23:40
Denunciar

bueno esto era una boludez, tenia seleccionada eth0 la pase a la inalambrica y no aparece mas el error, pero no captura nada... Estoy probando loguearme desde otra maquina de la red local conectada a la misma wifi abierta... probe tambien con el firefox como root y no pasa nada... que puede ser?

Por  Ardillas en la red
publicado el 25 enero a las 22:13
Denunciar

Cuando trato de iniciar la captura me aparece

"Error: Coudn't get ip/netmask for device eth0: eth0: no IPv4 address assigned"

Configure manualmente la eth0 por las dudas pero sigue pasando lo mismo, algun idea?